# certifi bundles emSign root CAs with compromised intermediate CA keys

Advisory record · `GHSA-6q48-6c7w-9gw2`

- **Identifiers:** `GHSA-6q48-6c7w-9gw2` · `PYSEC-2026-4320`
- **State:** Confirmed
- **Severity:** CVSS 4.0, no score published
- **Critical:** No
- **Published:** 20 Oct 2026
- **Updated:** 30 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Oct 2026, 21:41 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `certifi` (PyPI): affected `>=2019.03.09, <2026.10.18`; fixed in `2026.10.18`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Certifi versions from 2019.03.09 before 2026.10.18 bundle the emSign ECC Root CA - G3 root certificate, and eight eMudhra intermediate CA certificates chaining to it have compromised private keys that the CA has revoked. An attacker holding one of those keys could issue certificates for any hostname and, if also positioned on-path, intercept or modify TLS traffic from clients that trust the bundle, such as requests, urllib3, pip, and the Python.org macOS installer. Upgrade to certifi 2026.10.19 or later, and rebuild container images that vendor certifi.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- Score not published, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`, from OSV

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/PYSEC-2026-4320)

## Sources

- [GitHub Advisory Database: GHSA-6q48-6c7w-9gw2](https://github.com/advisories/GHSA-6q48-6c7w-9gw2)
- [OSV: GHSA-6q48-6c7w-9gw2](https://osv.dev/vulnerability/GHSA-6q48-6c7w-9gw2)
- <https://github.com/certifi/python-certifi/security/advisories/GHSA-6q48-6c7w-9gw2>
- <https://discuss.python.org/t/information-for-python-users-regarding-emudhra-emsign-ca-certificate-security-incident/109576>
- <https://emudhra.we-have-a-problem.com/>
- <https://github.com/certifi/python-certifi>
- <https://pypi.org/project/certifi>
- <https://github.com/advisories/GHSA-6q48-6c7w-9gw2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-6q48-6c7w-9gw2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-6q48-6c7w-9gw2/>. Everything for agents: <https://agentprime.io/llms.txt>.
