# qs : qs.stringify with arrayFormat 'comma' throws an uncaught TypeError on array elements carrying a non-callable own toString (DoS)

Advisory record · `GHSA-6pq8-jhm2-2vcw`

- **Identifiers:** `GHSA-6pq8-jhm2-2vcw` · `CVE-2026-110816`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-248](https://cwe.mitre.org/data/definitions/248.html) · [CWE-704](https://cwe.mitre.org/data/definitions/704.html)
- **Tags:** [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md) · [CWE-704](https://agentprime.io/advisories/tag/cwe-704.md)
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Oct 2026, 16:10 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `qs` (npm): affected `>=6.7.0, <6.16.1`; fixed in `6.16.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Packages qs from 6.7.0 before 6.16.1 throw an uncaught TypeError from qs.stringify when arrayFormat is 'comma' and an array element is an object whose own toString is not callable. An attacker who can influence an object that the application later serializes with that option can trigger the throw, which crashes a Node process that has no synchronous error boundary around the call. The fix is to upgrade qs to 6.16.1 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`, from CNA (harborist)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0037, the 30th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-6pq8-jhm2-2vcw)

## Sources

- [GitHub Advisory Database: GHSA-6pq8-jhm2-2vcw](https://github.com/advisories/GHSA-6pq8-jhm2-2vcw)
- [OSV: GHSA-6pq8-jhm2-2vcw](https://osv.dev/vulnerability/GHSA-6pq8-jhm2-2vcw)
- <https://github.com/ljharb/qs/security/advisories/GHSA-6pq8-jhm2-2vcw>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-110816>
- <https://github.com/ljharb/qs/commit/a952e7519338ef0cfb25694a2988848f93333727>
- <https://github.com/ljharb/qs>
- <https://github.com/ljharb/qs/releases/tag/v6.16.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-6pq8-jhm2-2vcw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-6pq8-jhm2-2vcw/>. Everything for agents: <https://agentprime.io/llms.txt>.
