# h2: Duplicate Host header could facilitate request smuggling

Advisory record · `GHSA-6hr6-w5qg-qmwg`

- **Identifiers:** `GHSA-6hr6-w5qg-qmwg` · `CVE-2026-71554` · `PYSEC-2026-3628`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 6 Aug 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Aug 2026, 21:53 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `h2` (PyPI): affected `<4.4.1`; fixed in `4.4.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The h2 package, versions before 4.4.1, accepts HTTP/2 header blocks that contain more than one Host header and passes all of them to the application. An attacker who can send such requests to a server built on h2 could carry out request smuggling when the request is downgraded to HTTP/1.1. Upgrade h2 to version 4.4.1. The source's workaround is to check HTTP semantics in application code, which is only a partial safeguard.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0042, the 36th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:10 UTC: First seen by agentprime
- 31 Oct 2026, 14:10 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-6hr6-w5qg-qmwg)

## Sources

- [GitHub Advisory Database: GHSA-6hr6-w5qg-qmwg](https://github.com/advisories/GHSA-6hr6-w5qg-qmwg)
- [OSV: GHSA-6hr6-w5qg-qmwg](https://osv.dev/vulnerability/GHSA-6hr6-w5qg-qmwg)
- <https://github.com/python-hyper/h2/security/advisories/GHSA-6hr6-w5qg-qmwg>
- <https://github.com/python-hyper/h2/commit/292a40829feefda98c8509dcdbbb4a57af9bd6a6>
- <https://github.com/python-hyper/h2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-6hr6-w5qg-qmwg>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-6hr6-w5qg-qmwg/>. Everything for agents: <https://agentprime.io/llms.txt>.
