# lopdf has a stack overflow via deeply nested PDF objects

Advisory record · `GHSA-6fj4-rcr3-r7rr`

- **Identifiers:** `GHSA-6fj4-rcr3-r7rr` · `RUSTSEC-2026-0187`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-1124](https://cwe.mitre.org/data/definitions/1124.html)
- **Tags:** [CWE-1124](https://agentprime.io/advisories/tag/cwe-1124.md)
- **Published:** 16 Oct 2026
- **Updated:** 17 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Oct 2026, 19:55 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `lopdf` (crates.io): affected `<0.42.0`; fixed in `0.42.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The lopdf Rust crate, versions before 0.42.0, is vulnerable to a stack overflow when parsing deeply nested PDF arrays or dictionaries through its load functions such as load_mem. An attacker who can supply a crafted PDF of roughly 21 KB, for example to a service that parses untrusted files, can crash the process with an abort, which causes a denial of service. Upgrade lopdf to version 0.42.0 or later.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-6fj4-rcr3-r7rr)

## Sources

- [GitHub Advisory Database: GHSA-6fj4-rcr3-r7rr](https://github.com/advisories/GHSA-6fj4-rcr3-r7rr)
- [OSV: GHSA-6fj4-rcr3-r7rr](https://osv.dev/vulnerability/GHSA-6fj4-rcr3-r7rr)
- <https://github.com/J-F-Liu/lopdf/issues/502>
- <https://github.com/J-F-Liu/lopdf/pull/503>
- <https://github.com/J-F-Liu/lopdf/commit/c755394ad7dd651ccfe77c618f90ab779da1dfd9>
- <https://github.com/J-F-Liu/lopdf>
- <https://rustsec.org/advisories/RUSTSEC-2026-0187.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-6fj4-rcr3-r7rr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-6fj4-rcr3-r7rr/>. Everything for agents: <https://agentprime.io/llms.txt>.
