# Ray Missing Authorization vulnerability

Advisory record · `GHSA-6cxr-8q3m-jwrr`

- **Identifiers:** `GHSA-6cxr-8q3m-jwrr` · `CVE-2023-6020` · `PYSEC-2026-516`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** Yes: CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-598](https://cwe.mitre.org/data/definitions/598.html) · [CWE-862](https://cwe.mitre.org/data/definitions/862.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-598](https://agentprime.io/advisories/tag/cwe-598.md)
- **Published:** 16 Nov 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Nov 2023, 21:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 7.5 (7.0 or more) and EPSS 0.15 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `ray` (PyPI): affected `<2.8.1`; fixed in `2.8.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Ray versions before 2.8.1 are vulnerable to a local file inclusion flaw in the /static/ directory. An unauthenticated attacker with network access to the server can read arbitrary files on it. Upgrade ray to version 2.8.1 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (@huntr_ai)

- **CISA KEV:** Not listed.
- **EPSS:** 0.15, the 96th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:36 UTC: First seen by agentprime
- 31 Oct 2026, 14:36 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-6cxr-8q3m-jwrr)

## Sources

- [GitHub Advisory Database: GHSA-6cxr-8q3m-jwrr](https://github.com/advisories/GHSA-6cxr-8q3m-jwrr)
- [OSV: GHSA-6cxr-8q3m-jwrr](https://osv.dev/vulnerability/GHSA-6cxr-8q3m-jwrr)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-6020>
- <https://github.com/ray-project/ray>
- <https://github.com/ray-project/ray/releases/tag/ray-2.8.1>
- <https://huntr.com/bounties/83dd8619-6dc3-4c98-8f1b-e620fedcd1f6>
- <https://www.anyscale.com/blog/update-on-ray-cves-cve-2023-6019-cve-2023-6020-cve-2023-6021-cve-2023-48022-cve-2023-48023>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-6cxr-8q3m-jwrr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-6cxr-8q3m-jwrr/>. Everything for agents: <https://agentprime.io/llms.txt>.
