# Netty: Security Control Bypass via CORS Short-Circuit Failure

Advisory record · `GHSA-6cqp-g7gg-8hr5`

- **Identifiers:** `GHSA-6cqp-g7gg-8hr5` · `CVE-2026-56746`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-284](https://cwe.mitre.org/data/definitions/284.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md)
- **Published:** 22 Jul 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Jul 2026, 21:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `io.netty:netty-codec-http` (Maven): affected `>=4.2.0.Final, <4.2.16.Final || <4.1.136.Final`; fixed in `4.2.16.Final`, `4.1.136.Final`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Netty's netty-codec-http package, versions 4.2.0.Final before 4.2.16.Final and versions before 4.1.136.Final, has a flaw in its CORS handler where the shortCircuit() setting can be bypassed. An attacker who can send HTTP requests can send an Origin: null header to get unauthorized cross-origin requests forwarded to the backend application, bypassing access controls. Upgrade to 4.2.16.Final or 4.1.136.Final.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0041, the 35th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-6cqp-g7gg-8hr5)

## Sources

- [GitHub Advisory Database: GHSA-6cqp-g7gg-8hr5](https://github.com/advisories/GHSA-6cqp-g7gg-8hr5)
- [OSV: GHSA-6cqp-g7gg-8hr5](https://osv.dev/vulnerability/GHSA-6cqp-g7gg-8hr5)
- <https://github.com/netty/netty/security/advisories/GHSA-6cqp-g7gg-8hr5>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-56746>
- <https://github.com/netty/netty>
- <https://github.com/netty/netty/releases/tag/netty-4.1.136.Final>
- <https://github.com/netty/netty/releases/tag/netty-4.2.16.Final>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-6cqp-g7gg-8hr5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-6cqp-g7gg-8hr5/>. Everything for agents: <https://agentprime.io/llms.txt>.
