# Babel vulnerable to arbitrary code execution when compiling specifically crafted malicious code

Advisory record · `GHSA-67hx-6x53-jw92`

- **Identifiers:** `GHSA-67hx-6x53-jw92` · `CVE-2023-45133`
- **State:** Confirmed
- **Severity:** CVSS 9.4 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-184](https://cwe.mitre.org/data/definitions/184.html) · [CWE-697](https://cwe.mitre.org/data/definitions/697.html)
- **Tags:** [CWE-184](https://agentprime.io/advisories/tag/cwe-184.md) · [CWE-697](https://agentprime.io/advisories/tag/cwe-697.md)
- **Published:** 16 Oct 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Oct 2023, 13:55 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.4: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `@babel/traverse` (npm): affected `<7.23.2 || >=8.0.0-alpha.0, <8.0.0-alpha.4`; fixed in `7.23.2`, `8.0.0-alpha.4`
- `babel-traverse` (npm): affected `all versions`; no fixed version yet

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.4 Critical, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0053, the 44th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 16 Oct 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-67hx-6x53-jw92](https://github.com/advisories/GHSA-67hx-6x53-jw92)
- [OSV: GHSA-67hx-6x53-jw92](https://osv.dev/vulnerability/GHSA-67hx-6x53-jw92)
- <https://github.com/babel/babel/security/advisories/GHSA-67hx-6x53-jw92>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-45133>
- <https://github.com/babel/babel/pull/16033>
- <https://github.com/babel/babel/commit/b13376b346946e3f62fc0848c1d2a23223314c82>
- <https://babeljs.io/blog/2023/10/16/cve-2023-45133>
- <https://github.com/babel/babel>
- <https://github.com/babel/babel/releases/tag/v7.23.2>
- <https://github.com/babel/babel/releases/tag/v8.0.0-alpha.4>
- <https://lists.debian.org/debian-lts-announce/2023/10/msg00026.html>
- <https://www.debian.org/security/2023/dsa-5528>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-67hx-6x53-jw92>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-67hx-6x53-jw92/>. Everything for agents: <https://agentprime.io/llms.txt>.
