# gRPC Reachable Assertion issue

Advisory record · `GHSA-6628-q6j9-w8vg`

- **Identifiers:** `GHSA-6628-q6j9-w8vg` · `CVE-2023-1428` · `PYSEC-2026-1425`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-617](https://cwe.mitre.org/data/definitions/617.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 6 Jul 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Jul 2023, 21:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `io.grpc:grpc-protobuf` (Maven): affected `>=1.51.0, <1.53.0`; fixed in `1.53.0`
- `grpcio` (PyPI): affected `>=1.51.0, <1.53.0`; fixed in `1.53.0`
- `grpc` (RubyGems): affected `>=1.51.0, <1.53.0`; fixed in `1.53.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The gRPC C++ implementation, as shipped in io.grpc:grpc-protobuf (Maven), grpcio (PyPI), and grpc (RubyGems) versions 1.51.0 up to but not including 1.53.0, can be made to call abort() when it receives certain HTTP/2 headers. An attacker who can send HTTP/2 requests to a gRPC server can crash it by sending one of these headers followed by a later header that pushes the total header size past 8KB. Upgrade to version 1.53.0 or later.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (Google)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0041, the 35th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:18 UTC: First seen by agentprime
- 31 Oct 2026, 14:18 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-6628-q6j9-w8vg)

## Sources

- [GitHub Advisory Database: GHSA-6628-q6j9-w8vg](https://github.com/advisories/GHSA-6628-q6j9-w8vg)
- [OSV: GHSA-6628-q6j9-w8vg](https://osv.dev/vulnerability/GHSA-6628-q6j9-w8vg)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-1428>
- <https://github.com/grpc/grpc/issues/33463>
- <https://github.com/grpc/grpc/commit/2485fa94bd8a723e5c977d55a3ce10b301b437f8>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/grpc/CVE-2023-1428.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-6628-q6j9-w8vg>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-6628-q6j9-w8vg/>. Everything for agents: <https://agentprime.io/llms.txt>.
