# Highcharts Core: HTML text parsing falls back to unfiltered \`innerHTML\` during printing

Advisory record · `GHSA-65hg-cf3f-5m39`

- **Identifiers:** `GHSA-65hg-cf3f-5m39` · `CVE-2026-118244`
- **State:** Confirmed
- **Severity:** CVSS 7.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Oct 2026, 19:55 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `highcharts` (npm): affected `>=12.0.0, <12.6.1 || >=13.0.0, <13.1.0`; fixed in `12.6.1`, `13.1.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Highcharts npm package versions 12.0.0 up to 12.6.1 and 13.0.0 up to 13.1.0 are affected by an HTML text parsing fallback that inserts unfiltered markup into the page. When the hosting page re-renders the chart from a beforeprint handler in Chromium, HTML-rendered text options such as titles, labels and responsive-rule text can carry event handlers that run in the host page's origin, and printing from the exporting menu triggers this. The fix is to upgrade to version 12.6.1 or 13.1.0, or to apply the workaround given in the source for other affected versions.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.2 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0034, the 27th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-65hg-cf3f-5m39)

## Sources

- [GitHub Advisory Database: GHSA-65hg-cf3f-5m39](https://github.com/advisories/GHSA-65hg-cf3f-5m39)
- [OSV: GHSA-65hg-cf3f-5m39](https://osv.dev/vulnerability/GHSA-65hg-cf3f-5m39)
- <https://github.com/highcharts/highcharts/security/advisories/GHSA-65hg-cf3f-5m39>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-118244>
- <https://github.com/highcharts/highcharts/commit/abde7c576793bf50b0e0636e59b49630de6dd0d5>
- <https://github.com/highcharts/highcharts>
- <https://github.com/highcharts/highcharts/releases/tag/v13.1.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-65hg-cf3f-5m39>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-65hg-cf3f-5m39/>. Everything for agents: <https://agentprime.io/llms.txt>.
