# Dasel: Selector lexer panics on trailing whitespace in \`parseCurRune\`

Advisory record · `GHSA-65gg-g7rw-6cpc`

- **Identifiers:** `GHSA-65gg-g7rw-6cpc` · `CVE-2026-62866` · `GO-2026-6548`
- **State:** Confirmed
- **Severity:** CVSS 6.2 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-129](https://cwe.mitre.org/data/definitions/129.html)
- **Tags:** [CWE-129](https://agentprime.io/advisories/tag/cwe-129.md)
- **Published:** 22 Sept 2026
- **Updated:** 1 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Sept 2026, 19:52 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/tomwright/dasel/v3` (Go): affected `>=3.0.0, <3.11.2`; fixed in `3.11.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GHSA-65gg-g7rw-6cpc: Dasel's selector lexer in github.com/tomwright/dasel/v3, versions 3.0.0 up to 3.11.2, panics when a selector ends in whitespace, such as "a ". Any user or caller who can pass a selector to the query function can crash the process, with no authentication needed. Upgrade to version 3.11.2 or later, which contains the fix. The source gives few other details.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.2 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0019, the 8th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:12 UTC: First seen by agentprime
- 31 Oct 2026, 14:12 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-65gg-g7rw-6cpc)

## Sources

- [GitHub Advisory Database: GHSA-65gg-g7rw-6cpc](https://github.com/advisories/GHSA-65gg-g7rw-6cpc)
- [OSV: GHSA-65gg-g7rw-6cpc](https://osv.dev/vulnerability/GHSA-65gg-g7rw-6cpc)
- <https://github.com/TomWright/dasel/security/advisories/GHSA-65gg-g7rw-6cpc>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-62866>
- <https://github.com/TomWright/dasel/commit/eee03aec28d4a33d6138098d065b7b37b85e3c55>
- <https://github.com/TomWright/dasel>
- <https://github.com/TomWright/dasel/releases/tag/v3.11.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-65gg-g7rw-6cpc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-65gg-g7rw-6cpc/>. Everything for agents: <https://agentprime.io/llms.txt>.
