# CodeWhale: Project config \`instructions\` override enables arbitrary file read into AI system prompt via cloned repository

Advisory record · `GHSA-62f5-cp2p-vq95`

- **Identifiers:** `GHSA-62f5-cp2p-vq95` · `CVE-2026-75859`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html) · [CWE-200](https://cwe.mitre.org/data/definitions/200.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md) · [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md)
- **Published:** 4 Sept 2026
- **Updated:** 4 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 4 Sept 2026, 18:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `deepseek-tui` (crates.io): affected `>=0.8.8`; no fixed version yet
- `deepseek-tui` (npm): affected `>=0.8.8, <0.8.41`; fixed in `0.8.41`
- `codewhale-tui` (crates.io): affected `>=0.8.41, <0.8.64`; fixed in `0.8.64`
- `codewhale` (npm): affected `>=0.8.41, <0.8.64`; fixed in `0.8.64`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0053, the 45th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 4 Sept 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-62f5-cp2p-vq95](https://github.com/advisories/GHSA-62f5-cp2p-vq95)
- [OSV: GHSA-62f5-cp2p-vq95](https://osv.dev/vulnerability/GHSA-62f5-cp2p-vq95)
- <https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-62f5-cp2p-vq95>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-75859>
- <https://github.com/Hmbown/CodeWhale/commit/43563356b98c6b993085554da82e77370160a31c>
- <https://github.com/Hmbown/CodeWhale>
- <https://www.vulncheck.com/advisories/codewhale-before-arbitrary-file-read-via-instructions>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-62f5-cp2p-vq95>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-62f5-cp2p-vq95/>. Everything for agents: <https://agentprime.io/llms.txt>.
