# Improper handling of double quotes in file name in Diffy in Windows environment

Advisory record · `GHSA-5ww9-9qp2-x524`

- **Identifiers:** `GHSA-5ww9-9qp2-x524` · `CVE-2022-33127`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Published:** 24 Jun 2022
- **Updated:** 8 Dec 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Jun 2022, 00:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `diffy` (RubyGems): affected `<3.4.1`; fixed in `3.4.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.018, the 79th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 24 Jun 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-5ww9-9qp2-x524](https://github.com/advisories/GHSA-5ww9-9qp2-x524)
- [OSV: GHSA-5ww9-9qp2-x524](https://osv.dev/vulnerability/GHSA-5ww9-9qp2-x524)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-33127>
- <https://github.com/samg/diffy/commit/478f392082b66d38f54a02b4bb9c41be32fd6593>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/diffy/CVE-2022-33127.yml>
- <https://github.com/samg/diffy>
- <https://github.com/samg/diffy/blob/56fd935aea256742f7352b050592542d3d153bf6/CHANGELOG#L1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5ww9-9qp2-x524>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5ww9-9qp2-x524/>. Everything for agents: <https://agentprime.io/llms.txt>.
