# Undefined behavior when users supply invalid resource handles

Advisory record · `GHSA-5wpj-c6f7-24x8`

- **Identifiers:** `GHSA-5wpj-c6f7-24x8` · `BIT-tensorflow-2022-29207` · `CVE-2022-29207` · `PYSEC-2026-3112` · `PYSEC-2026-3280` · `PYSEC-2026-955`
- **State:** Confirmed
- **Severity:** CVSS 5.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-475](https://cwe.mitre.org/data/definitions/475.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-475](https://agentprime.io/advisories/tag/cwe-475.md)
- **Published:** 24 May 2022
- **Updated:** 13 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 May 2022, 22:13 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `tensorflow` (PyPI): affected `<2.6.4 || >=2.7.0, <2.7.2 || >=2.8.0, <2.8.1`; fixed in `2.6.4`, `2.7.2`, `2.8.1`
- `tensorflow-cpu` (PyPI): affected `<2.6.4 || >=2.7.0, <2.7.2 || >=2.8.0, <2.8.1`; fixed in `2.6.4`, `2.7.2`, `2.8.1`
- `tensorflow-gpu` (PyPI): affected `<2.6.4 || >=2.7.0, <2.7.2 || >=2.8.0, <2.8.1`; fixed in `2.6.4`, `2.7.2`, `2.8.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.5 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0032, the 25th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:59 UTC: First seen by agentprime
- 31 Oct 2026, 14:59 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-5wpj-c6f7-24x8)

## Sources

- [GitHub Advisory Database: GHSA-5wpj-c6f7-24x8](https://github.com/advisories/GHSA-5wpj-c6f7-24x8)
- [OSV: GHSA-5wpj-c6f7-24x8](https://osv.dev/vulnerability/GHSA-5wpj-c6f7-24x8)
- <https://github.com/tensorflow/tensorflow/security/advisories/GHSA-5wpj-c6f7-24x8>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-29207>
- <https://github.com/tensorflow/tensorflow/commit/a5b89cd68c02329d793356bda85d079e9e69b4e7>
- <https://github.com/tensorflow/tensorflow/commit/dbdd98c37bc25249e8f288bd30d01e118a7b4498>
- <https://github.com/tensorflow/tensorflow>
- <https://github.com/tensorflow/tensorflow/releases/tag/v2.6.4>
- <https://github.com/tensorflow/tensorflow/releases/tag/v2.7.2>
- <https://github.com/tensorflow/tensorflow/releases/tag/v2.8.1>
- <https://github.com/tensorflow/tensorflow/releases/tag/v2.9.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5wpj-c6f7-24x8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5wpj-c6f7-24x8/>. Everything for agents: <https://agentprime.io/llms.txt>.
