# Laravel relationship inclusion can trigger unauthorized data destruction

Advisory record · `GHSA-5wcm-3v2w-8362`

- **Identifiers:** `GHSA-5wcm-3v2w-8362` · `CVE-2026-114508` · `PKSA-4hy6-m98j-dz9f`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-470](https://cwe.mitre.org/data/definitions/470.html)
- **Tags:** [Code injection](https://agentprime.io/advisories/tag/code-injection.md)
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Oct 2026, 21:47 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `laravel/framework` (Packagist): affected `>=12.45.0, <12.68.0 || >=13.0.0, <13.27.0`; fixed in `12.68.0`, `13.27.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The Packagist package laravel/framework is affected in versions 12.45.0 up to but not including 12.68.0, and 13.0.0 up to but not including 13.27.0. The source says that under specific conditions, a request to a read-only endpoint that includes relationships can trigger a destructive database operation on a related table, so a user with only read access could cause data loss. Upgrade to laravel/framework 12.68.0 or 13.27.0 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0041, the 35th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:53 UTC: First seen by agentprime
- 31 Oct 2026, 13:53 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-5wcm-3v2w-8362)

## Sources

- [GitHub Advisory Database: GHSA-5wcm-3v2w-8362](https://github.com/advisories/GHSA-5wcm-3v2w-8362)
- [OSV: GHSA-5wcm-3v2w-8362](https://osv.dev/vulnerability/GHSA-5wcm-3v2w-8362)
- <https://github.com/laravel/framework/security/advisories/GHSA-5wcm-3v2w-8362>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-114508>
- <https://github.com/laravel/framework/pull/61322>
- <https://github.com/laravel/framework/pull/61323>
- <https://github.com/laravel/framework/commit/50a7970efe9f9990b6ec4f1e949de2abaaf4263e>
- <https://github.com/laravel/framework/commit/b89f2944995d555bfda76dced1ef6c6b04ef17d8>
- <https://github.com/laravel/framework>
- <https://github.com/laravel/framework/releases/tag/v12.68.0>
- <https://github.com/laravel/framework/releases/tag/v13.27.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5wcm-3v2w-8362>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5wcm-3v2w-8362/>. Everything for agents: <https://agentprime.io/llms.txt>.
