# MPXJ: XXE Vulnerability in MerlinReader

Advisory record · `GHSA-5vvx-3h34-f3gj`

- **Identifiers:** `GHSA-5vvx-3h34-f3gj` · `CVE-2026-61570` · `PYSEC-2026-4107`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-611](https://cwe.mitre.org/data/definitions/611.html)
- **Tags:** [XML external entities (XXE)](https://agentprime.io/advisories/tag/xxe.md)
- **Published:** 22 Sept 2026
- **Updated:** 1 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Sept 2026, 20:34 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `net.sf.mpxj:mpxj` (Maven): affected `>=5.5.5, <16.4.1`; fixed in `16.4.1`
- `mpxj` (RubyGems): affected `>=5.5.5, <16.4.1`; fixed in `16.4.1`
- `MPXJ.Net` (NuGet): affected `>=5.5.5, <16.4.1`; fixed in `16.4.1`
- `net.sf.mpxj` (NuGet): affected `>=5.5.5, <16.4.1`; fixed in `16.4.1`
- `net.sf.mpxj-for-csharp` (NuGet): affected `>=5.5.5, <16.4.1`; fixed in `16.4.1`
- `net.sf.mpxj-for-vb` (NuGet): affected `>=5.5.5, <16.4.1`; fixed in `16.4.1`
- `mpxj` (PyPI): affected `>=5.5.5, <16.4.1`; fixed in `16.4.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> MPXJ versions from 5.5.5 before 16.4.1 are vulnerable to an XML external entity (XXE) flaw in the MerlinReader component, which parses XML from the ZTIMEINTERVALS column of Merlin project SQLite files. An attacker who supplies a crafted Merlin project file can read arbitrary files, though the source says the parsed data is unlikely to be available for exfiltration. Upgrade to version 16.4.1 or later, or only open Merlin project files from trusted sources.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0047, the 41st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:09 UTC: First seen by agentprime
- 31 Oct 2026, 14:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-5vvx-3h34-f3gj)

## Sources

- [GitHub Advisory Database: GHSA-5vvx-3h34-f3gj](https://github.com/advisories/GHSA-5vvx-3h34-f3gj)
- [OSV: GHSA-5vvx-3h34-f3gj](https://osv.dev/vulnerability/GHSA-5vvx-3h34-f3gj)
- <https://github.com/joniles/mpxj/security/advisories/GHSA-5vvx-3h34-f3gj>
- <https://github.com/joniles/mpxj/commit/6e8288bc4d1cd62842af298004dc74fe66fb0805>
- <https://github.com/joniles/mpxj>
- <https://github.com/joniles/mpxj/releases/tag/v16.4.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5vvx-3h34-f3gj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5vvx-3h34-f3gj/>. Everything for agents: <https://agentprime.io/llms.txt>.
