# Pterodactyl Panel vulnerable to authentication bypass due to improper user-provided security token verification

Advisory record · `GHSA-5vfx-8w6m-h3v4`

- **Identifiers:** `GHSA-5vfx-8w6m-h3v4` · `CVE-2021-41129` · `PKSA-56gp-gqk7-m2wf`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-287](https://cwe.mitre.org/data/definitions/287.html) · [CWE-502](https://cwe.mitre.org/data/definitions/502.html) · [CWE-639](https://cwe.mitre.org/data/definitions/639.html) · [CWE-807](https://cwe.mitre.org/data/definitions/807.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [Insecure deserialization](https://agentprime.io/advisories/tag/deserialization.md) · [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-807](https://agentprime.io/advisories/tag/cwe-807.md)
- **Published:** 4 Oct 2021
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 4 Oct 2021, 20:14 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pterodactyl/panel` (Packagist): affected `>=1.0.0, <1.6.2`; fixed in `1.6.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.018, the 78th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 4 Oct 2021. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-5vfx-8w6m-h3v4](https://github.com/advisories/GHSA-5vfx-8w6m-h3v4)
- [OSV: GHSA-5vfx-8w6m-h3v4](https://osv.dev/vulnerability/GHSA-5vfx-8w6m-h3v4)
- <https://github.com/pterodactyl/panel/security/advisories/GHSA-5vfx-8w6m-h3v4>
- <https://nvd.nist.gov/vuln/detail/CVE-2021-41129>
- <https://github.com/pterodactyl/panel/commit/4a84c36009be10dbd83051ac1771662c056e4977>
- <https://github.com/pterodactyl/panel>
- <https://github.com/pterodactyl/panel/blob/v1.6.2/CHANGELOG.md#v162>
- <https://github.com/pterodactyl/panel/releases/tag/v1.6.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5vfx-8w6m-h3v4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5vfx-8w6m-h3v4/>. Everything for agents: <https://agentprime.io/llms.txt>.
