# Erlang Solutions MongooseIM vulnerable to denial of service (DoS) via crafted XMPP stream

Advisory record · `GHSA-5v5w-44w6-q5hv`

- **Identifiers:** `GHSA-5v5w-44w6-q5hv` · `CVE-2014-2829`
- **State:** Confirmed
- **Severity:** CVSS 4.0, no score published
- **Critical:** No
- **Weakness (CWE):** [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 17 May 2022
- **Updated:** 10 Dec 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 May 2022, 04:47 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `MongooseIM` (Hex): affected `<1.3.2`; fixed in `1.3.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- Score not published, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.020, the 80th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:26 UTC: First seen by agentprime
- 31 Oct 2026, 15:26 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-5v5w-44w6-q5hv)

## Sources

- [GitHub Advisory Database: GHSA-5v5w-44w6-q5hv](https://github.com/advisories/GHSA-5v5w-44w6-q5hv)
- [OSV: GHSA-5v5w-44w6-q5hv](https://osv.dev/vulnerability/GHSA-5v5w-44w6-q5hv)
- <https://nvd.nist.gov/vuln/detail/CVE-2014-2829>
- <https://github.com/esl/MongooseIM/commit/586d96cc12ef218243a3466354b4d208b5472a6c>
- <https://github.com/esl/MongooseIM>
- <http://xmpp.org/resources/security-notices/uncontrolled-resource-consumption-with-highly-compressed-xmpp-stanzas>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5v5w-44w6-q5hv>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5v5w-44w6-q5hv/>. Everything for agents: <https://agentprime.io/llms.txt>.
