# Improper Handling of Length Parameter Inconsistency in Apache Ant

Advisory record · `GHSA-5v34-g2px-j4fw`

- **Identifiers:** `GHSA-5v34-g2px-j4fw` · `CVE-2021-36374`
- **State:** Confirmed
- **Severity:** CVSS 5.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-130](https://cwe.mitre.org/data/definitions/130.html)
- **Tags:** [CWE-130](https://agentprime.io/advisories/tag/cwe-130.md)
- **Published:** 2 Aug 2021
- **Updated:** 1 Mar 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 2 Aug 2021, 16:56 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.ant:ant` (Maven): affected `>=1.9.0, <1.9.16 || >=1.10.0, <1.10.11`; fixed in `1.9.16`, `1.10.11`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.5 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.026, the 85th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 2 Aug 2021. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-5v34-g2px-j4fw](https://github.com/advisories/GHSA-5v34-g2px-j4fw)
- [OSV: GHSA-5v34-g2px-j4fw](https://osv.dev/vulnerability/GHSA-5v34-g2px-j4fw)
- <https://nvd.nist.gov/vuln/detail/CVE-2021-36374>
- <https://ant.apache.org/security.html>
- <https://lists.apache.org/thread.html/r27919fd4db07c487239c1d9771f480d89ce5ee2750aa9447309b709a@%3Ccommits.groovy.apache.org%3E>
- <https://lists.apache.org/thread.html/r544c9e8487431768465b8b2d13982c75123109bd816acf839d46010d@%3Ccommits.groovy.apache.org%3E>
- <https://lists.apache.org/thread.html/rad36f470647c5a7c02dd78c9973356d2840766d132b597b6444e373a@%3Cnotifications.groovy.apache.org%3E>
- <https://lists.apache.org/thread.html/rdd5412a5b9a25aed2a02c3317052d38a97128314d50bc1ed36e81d38%40%3Cuser.ant.apache.org%3E>
- <https://lists.apache.org/thread.html/rf4bb79751a02889623195715925e4fd8932dd3c97e0ade91395a96c6@%3Cdev.myfaces.apache.org%3E>
- <https://security.netapp.com/advisory/ntap-20210819-0007>
- <https://www.oracle.com/security-alerts/cpuapr2022.html>
- <https://www.oracle.com/security-alerts/cpujan2022.html>
- <https://www.oracle.com/security-alerts/cpujul2022.html>
- <https://www.oracle.com/security-alerts/cpuoct2021.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5v34-g2px-j4fw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5v34-g2px-j4fw/>. Everything for agents: <https://agentprime.io/llms.txt>.
