# Microsoft Security Advisory CVE-2025-55315: .NET Security Feature Bypass Vulnerability

Advisory record · `GHSA-5rrx-jjjq-q2r5`

- **Identifiers:** `GHSA-5rrx-jjjq-q2r5` · `BIT-aspnet-core-2025-55315` · `CVE-2025-55315`
- **State:** Confirmed
- **Severity:** CVSS 9.9 Critical
- **Critical:** Yes: CVSS 9+, CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 14 Oct 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 Oct 2025, 20:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.9: 9.0 or more.
- CVSS score 9.9 (7.0 or more) and EPSS 0.67 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `Microsoft.AspNetCore.Server.Kestrel.Core` (NuGet): affected `<2.3.6`; fixed in `2.3.6`
- `Microsoft.AspNetCore.App.Runtime.linux-arm` (NuGet): affected `>=10.0.0-rc.1.25451.107, <10.0.0-rc.2.25502.107 || >=9.0.0, <9.0.10 || >=8.0.0, <8.0.21`; fixed in `10.0.0-rc.2.25502.107`, `9.0.10`, `8.0.21`
- `Microsoft.AspNetCore.App.Runtime.linux-arm64` (NuGet): affected `>=10.0.0-rc.1.25451.107, <10.0.0-rc.2.25502.107 || >=9.0.0, <9.0.10 || >=8.0.0, <8.0.21`; fixed in `10.0.0-rc.2.25502.107`, `9.0.10`, `8.0.21`
- `Microsoft.AspNetCore.App.Runtime.linux-musl-arm` (NuGet): affected `>=10.0.0-rc.1.25451.107, <10.0.0-rc.2.25502.107 || >=9.0.0, <9.0.10 || >=8.0.0, <8.0.21`; fixed in `10.0.0-rc.2.25502.107`, `9.0.10`, `8.0.21`
- `Microsoft.AspNetCore.App.Runtime.linux-musl-arm64` (NuGet): affected `>=10.0.0-rc.1.25451.107, <10.0.0-rc.2.25502.107 || >=9.0.0, <9.0.10 || >=8.0.0, <8.0.21`; fixed in `10.0.0-rc.2.25502.107`, `9.0.10`, `8.0.21`
- `Microsoft.AspNetCore.App.Runtime.linux-musl-x64` (NuGet): affected `>=10.0.0-rc.1.25451.107, <10.0.0-rc.2.25502.107 || >=9.0.0, <9.0.10 || >=8.0.0, <8.0.21`; fixed in `10.0.0-rc.2.25502.107`, `9.0.10`, `8.0.21`
- `Microsoft.AspNetCore.App.Runtime.linux-x64` (NuGet): affected `>=10.0.0-rc.1.25451.107, <10.0.0-rc.2.25502.107 || >=9.0.0, <9.0.10 || >=8.0.0, <8.0.21`; fixed in `10.0.0-rc.2.25502.107`, `9.0.10`, `8.0.21`
- `Microsoft.AspNetCore.App.Runtime.osx-arm64` (NuGet): affected `>=10.0.0-rc.1.25451.107, <10.0.0-rc.2.25502.107 || >=9.0.0, <9.0.10 || >=8.0.0, <8.0.21`; fixed in `10.0.0-rc.2.25502.107`, `9.0.10`, `8.0.21`
- `Microsoft.AspNetCore.App.Runtime.osx-x64` (NuGet): affected `>=10.0.0-rc.1.25451.107, <10.0.0-rc.2.25502.107 || >=9.0.0, <9.0.10 || >=8.0.0, <8.0.21`; fixed in `10.0.0-rc.2.25502.107`, `9.0.10`, `8.0.21`
- `Microsoft.AspNetCore.App.Runtime.win-arm` (NuGet): affected `>=10.0.0-rc.1.25451.107, <10.0.0-rc.2.25502.107 || >=9.0.0, <9.0.10 || >=8.0.0, <8.0.21`; fixed in `10.0.0-rc.2.25502.107`, `9.0.10`, `8.0.21`
- `Microsoft.AspNetCore.App.Runtime.win-arm64` (NuGet): affected `>=10.0.0-rc.1.25451.107, <10.0.0-rc.2.25502.107 || >=9.0.0, <9.0.10 || >=8.0.0, <8.0.21`; fixed in `10.0.0-rc.2.25502.107`, `9.0.10`, `8.0.21`
- `Microsoft.AspNetCore.App.Runtime.win-x64` (NuGet): affected `>=10.0.0-rc.1.25451.107, <10.0.0-rc.2.25502.107 || >=9.0.0, <9.0.10 || >=8.0.0, <8.0.21`; fixed in `10.0.0-rc.2.25502.107`, `9.0.10`, `8.0.21`
- `Microsoft.AspNetCore.App.Runtime.win-x86` (NuGet): affected `>=10.0.0-rc.1.25451.107, <10.0.0-rc.2.25502.107 || >=9.0.0, <9.0.10 || >=8.0.0, <8.0.21`; fixed in `10.0.0-rc.2.25502.107`, `9.0.10`, `8.0.21`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.9 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L/E:U/RL:O/RC:C`, from CNA (microsoft)

- **CISA KEV:** Not listed.
- **EPSS:** 0.67, the 99th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:21 UTC: First seen by agentprime
- 31 Oct 2026, 15:21 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-5rrx-jjjq-q2r5)

## Sources

- [GitHub Advisory Database: GHSA-5rrx-jjjq-q2r5](https://github.com/advisories/GHSA-5rrx-jjjq-q2r5)
- [OSV: GHSA-5rrx-jjjq-q2r5](https://osv.dev/vulnerability/GHSA-5rrx-jjjq-q2r5)
- <https://github.com/dotnet/aspnetcore/security/advisories/GHSA-5rrx-jjjq-q2r5>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-55315>
- <https://github.com/dotnet/announcements/issues/371>
- <https://github.com/dotnet/aspnetcore>
- <https://msrc.microsoft.com/update-guide/vulnerability/CVE-2025-55315>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5rrx-jjjq-q2r5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5rrx-jjjq-q2r5/>. Everything for agents: <https://agentprime.io/llms.txt>.
