# Caddy: Unicode case-folding length expansion causes incorrect split_path index in FastCGI transport

Advisory record · `GHSA-5r3v-vc8m-m96g`

- **Identifiers:** `GHSA-5r3v-vc8m-m96g` · `CVE-2026-27590` · `GO-2026-4536`
- **State:** Confirmed
- **Severity:** CVSS 8.9 High
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-180](https://cwe.mitre.org/data/definitions/180.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-180](https://agentprime.io/advisories/tag/cwe-180.md)
- **Published:** 24 Feb 2026
- **Updated:** 27 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Feb 2026, 20:39 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/caddyserver/caddy/v2` (Go): affected `<2.11.1`; fixed in `2.11.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.9 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0061, the 49th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 24 Feb 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-5r3v-vc8m-m96g](https://github.com/advisories/GHSA-5r3v-vc8m-m96g)
- [OSV: GHSA-5r3v-vc8m-m96g](https://osv.dev/vulnerability/GHSA-5r3v-vc8m-m96g)
- <https://github.com/caddyserver/caddy/security/advisories/GHSA-5r3v-vc8m-m96g>
- <https://github.com/php/frankenphp/security/advisories/GHSA-g966-83w7-6w38>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-27590>
- <https://github.com/caddyserver/caddy>
- <https://github.com/caddyserver/caddy/releases/tag/v2.11.1>
- <https://pkg.go.dev/vuln/GO-2026-4536>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5r3v-vc8m-m96g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5r3v-vc8m-m96g/>. Everything for agents: <https://agentprime.io/llms.txt>.
