# poetry-plugin-tweak-dependencies-version affected by CVE-2026-25645

Advisory record · `GHSA-5qvp-pr9f-2g2v`

- **Identifiers:** `GHSA-5qvp-pr9f-2g2v`
- **State:** Confirmed
- **Severity:** CVSS 4.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-377](https://cwe.mitre.org/data/definitions/377.html)
- **Tags:** [CWE-377](https://agentprime.io/advisories/tag/cwe-377.md)
- **Published:** 1 Apr 2026
- **Updated:** 1 Apr 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Apr 2026, 20:52 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `poetry-plugin-tweak-dependencies-version` (PyPI): affected `<1.5.6`; fixed in `1.5.6`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.4 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 1 Apr 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-5qvp-pr9f-2g2v](https://github.com/advisories/GHSA-5qvp-pr9f-2g2v)
- [OSV: GHSA-5qvp-pr9f-2g2v](https://osv.dev/vulnerability/GHSA-5qvp-pr9f-2g2v)
- <https://github.com/psf/requests/security/advisories/GHSA-gc5v-m9x4-r6x2>
- <https://github.com/sbrunner/poetry-plugin-tweak-dependencies-version/security/advisories/GHSA-5qvp-pr9f-2g2v>
- <https://github.com/sbrunner/poetry-plugin-tweak-dependencies-version/commit/54b5784d89f36cd413a8bc5032ab0a96438dcae3>
- <https://github.com/sbrunner/poetry-plugin-tweak-dependencies-version>
- <https://github.com/sbrunner/poetry-plugin-tweak-dependencies-version/releases/tag/1.5.6>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5qvp-pr9f-2g2v>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5qvp-pr9f-2g2v/>. Everything for agents: <https://agentprime.io/llms.txt>.
