# RabbitMQ Java client: TrustEverythingTrustManager used by default in useSslProtocol() enables MITM

Advisory record · `GHSA-5m9f-rphj-c435`

- **Identifiers:** `GHSA-5m9f-rphj-c435` · `CVE-2026-63336`
- **State:** Confirmed
- **Severity:** CVSS 5.1 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-295](https://cwe.mitre.org/data/definitions/295.html)
- **Tags:** [Weak cryptography or TLS](https://agentprime.io/advisories/tag/weak-crypto.md)
- **Published:** 18 Aug 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Aug 2026, 16:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `com.rabbitmq:amqp-client` (Maven): affected `<5.33.0`; fixed in `5.33.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Affected versions of the RabbitMQ Java client (com.rabbitmq:amqp-client) before 5.33.0 use a trust manager that accepts any TLS certificate when ConnectionFactory.useSslProtocol() is called without arguments, and hostname verification is off by default. A network attacker positioned between client and broker could intercept traffic and read credentials. Upgrade to amqp-client 5.33.0 or later; until then, call useSslProtocol() with an explicit trust manager and enable hostname verification.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.1 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0031, the 23rd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-5m9f-rphj-c435)

## Sources

- [GitHub Advisory Database: GHSA-5m9f-rphj-c435](https://github.com/advisories/GHSA-5m9f-rphj-c435)
- [OSV: GHSA-5m9f-rphj-c435](https://osv.dev/vulnerability/GHSA-5m9f-rphj-c435)
- <https://github.com/rabbitmq/rabbitmq-java-client/security/advisories/GHSA-5m9f-rphj-c435>
- <https://github.com/rabbitmq/rabbitmq-java-client/pull/1999>
- <https://github.com/rabbitmq/rabbitmq-java-client/pull/2001>
- <https://github.com/rabbitmq/rabbitmq-java-client/commit/1e7deb2e6020c9793a81385a53ea378ec63b9339>
- <https://github.com/rabbitmq/rabbitmq-java-client/commit/a4bf571dd368765baaa9cecfae68ce09f1bdcc01>
- <https://github.com/rabbitmq/rabbitmq-java-client>
- <https://github.com/rabbitmq/rabbitmq-java-client/releases/tag/v5.33.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5m9f-rphj-c435>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5m9f-rphj-c435/>. Everything for agents: <https://agentprime.io/llms.txt>.
