# LlamaIndex vulnerable to data loss through hash collisions in its DocugamiReader class

Advisory record · `GHSA-5hq9-5r78-2gjh`

- **Identifiers:** `GHSA-5hq9-5r78-2gjh` · `CVE-2025-6211` · `PYSEC-2026-1566` · `PYSEC-2026-2606`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-440](https://cwe.mitre.org/data/definitions/440.html)
- **Tags:** [CWE-440](https://agentprime.io/advisories/tag/cwe-440.md)
- **Published:** 10 Jul 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 10 Jul 2025, 15:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `llama-index` (PyPI): affected `<0.12.41`; fixed in `0.12.41`
- `llama-index-readers-docugami` (PyPI): affected `<0.3.1`; fixed in `0.3.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`, from CNA (@huntr_ai)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0036, the 30th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:34 UTC: First seen by agentprime
- 31 Oct 2026, 14:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-5hq9-5r78-2gjh)

## Sources

- [GitHub Advisory Database: GHSA-5hq9-5r78-2gjh](https://github.com/advisories/GHSA-5hq9-5r78-2gjh)
- [OSV: GHSA-5hq9-5r78-2gjh](https://osv.dev/vulnerability/GHSA-5hq9-5r78-2gjh)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-6211>
- <https://github.com/run-llama/llama_index/commit/29b2e07e64ed7d302b1cc058185560b28eaa1352>
- <https://github.com/run-llama/llama_index>
- <https://huntr.com/bounties/1a48a011-a3c5-4979-9ffc-9652280bc389>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5hq9-5r78-2gjh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5hq9-5r78-2gjh/>. Everything for agents: <https://agentprime.io/llms.txt>.
