# libp2p-quic: Remote panic via certificate expiry race during QUIC handshake

Advisory record · `GHSA-5hq8-qhww-jm7q`

- **Identifiers:** `GHSA-5hq8-qhww-jm7q` · `CVE-2026-61544`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-248](https://cwe.mitre.org/data/definitions/248.html)
- **Tags:** [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md)
- **Published:** 15 Sept 2026
- **Updated:** 15 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Sept 2026, 20:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `libp2p-quic` (crates.io): affected `<0.13.1`; fixed in `0.13.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0028, the 20th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:17 UTC: First seen by agentprime
- 31 Oct 2026, 15:17 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-5hq8-qhww-jm7q)

## Sources

- [GitHub Advisory Database: GHSA-5hq8-qhww-jm7q](https://github.com/advisories/GHSA-5hq8-qhww-jm7q)
- [OSV: GHSA-5hq8-qhww-jm7q](https://osv.dev/vulnerability/GHSA-5hq8-qhww-jm7q)
- <https://github.com/libp2p/rust-libp2p/security/advisories/GHSA-5hq8-qhww-jm7q>
- <https://github.com/libp2p/rust-libp2p/pull/6525>
- <https://github.com/libp2p/rust-libp2p/commit/212f3774af048e2cecfb2e6b1e08477685e52b22>
- <https://github.com/libp2p/rust-libp2p/commit/e8f35e12c2418b04df6e9cdf036005e8aee3c7a2>
- <https://github.com/libp2p/rust-libp2p>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5hq8-qhww-jm7q>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5hq8-qhww-jm7q/>. Everything for agents: <https://agentprime.io/llms.txt>.
