# fast-jwt : Silent claim-validator bypass when JWT payload is a JSON array

Advisory record · `GHSA-5hjw-83fp-phq9`

- **Identifiers:** `GHSA-5hjw-83fp-phq9` · `CVE-2026-107723`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-1287](https://cwe.mitre.org/data/definitions/1287.html)
- **Tags:** [CWE-1287](https://agentprime.io/advisories/tag/cwe-1287.md)
- **Published:** 8 Oct 2026
- **Updated:** 8 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 8 Oct 2026, 22:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `fast-jwt` (npm): affected `<6.3.0`; fixed in `6.3.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The fast-jwt npm package, versions before 6.3.0, has a flaw in createVerifier: when a JWT with a valid signature carries a JSON array as its payload instead of an object, the verifier skips all configured claim checks (exp, nbf, iss, aud, sub, jti, nonce) and reports success after checking only the signature. An attacker needs a token signed with a key the verifier trusts, which might be held by another party or an issuer that accepts attacker-controlled payload content. Upgrade to fast-jwt 6.3.0 or later, which fixes the issue.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0046, the 39th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-5hjw-83fp-phq9)

## Sources

- [GitHub Advisory Database: GHSA-5hjw-83fp-phq9](https://github.com/advisories/GHSA-5hjw-83fp-phq9)
- [OSV: GHSA-5hjw-83fp-phq9](https://osv.dev/vulnerability/GHSA-5hjw-83fp-phq9)
- <https://github.com/nearform/fast-jwt/security/advisories/GHSA-5hjw-83fp-phq9>
- <https://github.com/nearform/fast-jwt/pull/639>
- <https://github.com/nearform/fast-jwt/commit/86e83efd8b5244f50859532d99244f0a9a9a4368>
- <https://github.com/nearform/fast-jwt>
- <https://github.com/nearform/fast-jwt/releases/tag/v6.3.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5hjw-83fp-phq9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5hjw-83fp-phq9/>. Everything for agents: <https://agentprime.io/llms.txt>.
