# Excelize: GetStyle panics on a negative fillId, borderId or fontId in styles.xml

Advisory record · `GHSA-5h23-36rv-pm65`

- **Identifiers:** `GHSA-5h23-36rv-pm65` · `CVE-2026-107225` · `GO-2026-6674`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-129](https://cwe.mitre.org/data/definitions/129.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-129](https://agentprime.io/advisories/tag/cwe-129.md)
- **Published:** 7 Oct 2026
- **Updated:** 5 Nov 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 7 Oct 2026, 20:22 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/xuri/excelize/v2` (Go): affected `>=2.8.0, <2.11.1-0.20260731010303-ae2113b410e5`; fixed in `2.11.1-0.20260731010303-ae2113b410e5`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GHSA-5h23-36rv-pm65 affects github.com/xuri/excelize/v2 versions from 2.8.0 up to 2.11.1-0.20260731010303-ae2113b410e5. A crafted .xlsx file with a negative fillId, borderId or fontId in its styles can make GetStyle panic on an out-of-range index, crashing any process that reads cell styling from an untrusted workbook. The source describes availability impact only. Upgrade to 2.11.1-0.20260731010303-ae2113b410e5, where this is fixed.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0027, the 19th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:12 UTC: First seen by agentprime
- 31 Oct 2026, 14:12 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-5h23-36rv-pm65)

## Sources

- [GitHub Advisory Database: GHSA-5h23-36rv-pm65](https://github.com/advisories/GHSA-5h23-36rv-pm65)
- [OSV: GHSA-5h23-36rv-pm65](https://osv.dev/vulnerability/GHSA-5h23-36rv-pm65)
- <https://github.com/qax-os/excelize/security/advisories/GHSA-5h23-36rv-pm65>
- <https://github.com/qax-os/excelize/pull/2367>
- <https://github.com/qax-os/excelize/commit/ae2113b410e51f6a141c396a59eda8c42b91bc22>
- <https://github.com/qax-os/excelize>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5h23-36rv-pm65>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5h23-36rv-pm65/>. Everything for agents: <https://agentprime.io/llms.txt>.
