# node-forge has an Interpretation Conflict vulnerability via its ASN.1 Validator Desynchronization

Advisory record · `GHSA-5gfm-wpxj-wjgq`

- **Identifiers:** `GHSA-5gfm-wpxj-wjgq` · `CVE-2025-12816`
- **State:** Confirmed
- **Severity:** CVSS 8.6 High
- **Critical:** No
- **Weakness (CWE):** [CWE-436](https://cwe.mitre.org/data/definitions/436.html)
- **Tags:** [CWE-436](https://agentprime.io/advisories/tag/cwe-436.md)
- **Published:** 26 Nov 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 Nov 2025, 22:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `node-forge` (npm): affected `<1.3.2`; fixed in `1.3.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.6 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0058, the 47th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 26 Nov 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-5gfm-wpxj-wjgq](https://github.com/advisories/GHSA-5gfm-wpxj-wjgq)
- [OSV: GHSA-5gfm-wpxj-wjgq](https://osv.dev/vulnerability/GHSA-5gfm-wpxj-wjgq)
- <https://github.com/digitalbazaar/forge/security/advisories/GHSA-5gfm-wpxj-wjgq>
- <https://github.com/digitalbazaar/forge/pull/1124>
- <https://github.com/digitalbazaar/forge>
- <https://github.com/digitalbazaar/forge/blob/2bb97afb5058285ef09bcf1d04d6bd6b87cffd58/lib/asn1.js#L1153>
- <https://github.com/digitalbazaar/forge/blob/2bb97afb5058285ef09bcf1d04d6bd6b87cffd58/lib/ed25519.js#L81>
- <https://github.com/digitalbazaar/forge/blob/2bb97afb5058285ef09bcf1d04d6bd6b87cffd58/lib/pbe.js#L363>
- <https://github.com/digitalbazaar/forge/blob/2bb97afb5058285ef09bcf1d04d6bd6b87cffd58/lib/pkcs12.js#L328>
- <https://github.com/digitalbazaar/forge/blob/2bb97afb5058285ef09bcf1d04d6bd6b87cffd58/lib/pkcs7.js#L90>
- <https://github.com/digitalbazaar/forge/blob/2bb97afb5058285ef09bcf1d04d6bd6b87cffd58/lib/rsa.js#L1167>
- <https://github.com/digitalbazaar/forge/blob/2bb97afb5058285ef09bcf1d04d6bd6b87cffd58/lib/x509.js#L667>
- <https://kb.cert.org/vuls/id/521113>
- <https://www.kb.cert.org/vuls/id/521113>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5gfm-wpxj-wjgq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5gfm-wpxj-wjgq/>. Everything for agents: <https://agentprime.io/llms.txt>.
