# Craft CMS has Twig Function Blocklist Bypass

Advisory record · `GHSA-5fvc-7894-ghp4`

- **Identifiers:** `GHSA-5fvc-7894-ghp4` · `CVE-2026-28783` · `PKSA-x1f7-3vrt-jvfj`
- **State:** Confirmed
- **Severity:** CVSS 9.4 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-94](https://cwe.mitre.org/data/definitions/94.html) · [CWE-184](https://cwe.mitre.org/data/definitions/184.html) · [CWE-1336](https://cwe.mitre.org/data/definitions/1336.html)
- **Tags:** [Code injection](https://agentprime.io/advisories/tag/code-injection.md) · [CWE-184](https://agentprime.io/advisories/tag/cwe-184.md)
- **Published:** 3 Mar 2026
- **Updated:** 4 Mar 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Mar 2026, 21:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.4: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `craftcms/cms` (Packagist): affected `>=5.0.0-RC1, <5.9.0-beta.1 || >=4.0.0-RC1, <4.17.0-beta.1`; fixed in `5.9.0-beta.1`, `4.17.0-beta.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.4 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0051, the 43rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 3 Mar 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-5fvc-7894-ghp4](https://github.com/advisories/GHSA-5fvc-7894-ghp4)
- [OSV: GHSA-5fvc-7894-ghp4](https://osv.dev/vulnerability/GHSA-5fvc-7894-ghp4)
- <https://github.com/craftcms/cms/security/advisories/GHSA-5fvc-7894-ghp4>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-28783>
- <https://github.com/craftcms/cms/pull/18208>
- <https://github.com/craftcms/cms>
- <https://github.com/twigphp/Twig/blob/946ddeafa3c9f4ce279d1f34051af041db0e16f2/src/Extension/CoreExtension.php#L2096>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5fvc-7894-ghp4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5fvc-7894-ghp4/>. Everything for agents: <https://agentprime.io/llms.txt>.
