# simpleSAMLphp incorrectly handles XML encryption

Advisory record · `GHSA-5fj7-f8x3-q2mc`

- **Identifiers:** `GHSA-5fj7-f8x3-q2mc` · `CVE-2011-4625` · `PKSA-hk9y-3wpr-11pk`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-755](https://cwe.mitre.org/data/definitions/755.html)
- **Tags:** [CWE-755](https://agentprime.io/advisories/tag/cwe-755.md)
- **Published:** 22 Apr 2022
- **Updated:** 12 Jan 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Apr 2022, 00:24 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `simplesamlphp/simplesamlphp` (Packagist): affected `<1.8.1`; fixed in `1.8.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0074, the 54th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 22 Apr 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-5fj7-f8x3-q2mc](https://github.com/advisories/GHSA-5fj7-f8x3-q2mc)
- [OSV: GHSA-5fj7-f8x3-q2mc](https://osv.dev/vulnerability/GHSA-5fj7-f8x3-q2mc)
- <https://nvd.nist.gov/vuln/detail/CVE-2011-4625>
- <https://github.com/simplesamlphp/simplesamlphp>
- <https://github.com/simplesamlphp/simplesamlphp/blob/b3059c51a915910c6631fb2ee597c0fb6ad9162b/docs/simplesamlphp-changelog-1.x.md?plain=1#L1624>
- <https://secure1.securityspace.com/smysecure/catid.html?in=DSA%202330-1>
- <https://security-tracker.debian.org/tracker/CVE-2011-4625>
- <https://www.mageni.net/vulnerability/debian-security-advisory-dsa-2330-1-simplesamlphp-70545>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5fj7-f8x3-q2mc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5fj7-f8x3-q2mc/>. Everything for agents: <https://agentprime.io/llms.txt>.
