# avo vulnerable to Stored XSS (Cross Site Scripting) in html content based fields

Advisory record · `GHSA-5cr9-5jx3-2g39`

- **Identifiers:** `GHSA-5cr9-5jx3-2g39` · `CVE-2023-34103`
- **State:** Confirmed
- **Severity:** CVSS 7.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 6 Jun 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Jun 2023, 14:13 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `avo` (RubyGems): affected `<2.33.3 || >=3.0.0.pre1, <=3.0.0.pre12`; fixed in `2.33.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.3 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0056, the 46th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-5cr9-5jx3-2g39)

## Sources

- [GitHub Advisory Database: GHSA-5cr9-5jx3-2g39](https://github.com/advisories/GHSA-5cr9-5jx3-2g39)
- [OSV: GHSA-5cr9-5jx3-2g39](https://osv.dev/vulnerability/GHSA-5cr9-5jx3-2g39)
- <https://github.com/avo-hq/avo/security/advisories/GHSA-5cr9-5jx3-2g39>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-34103>
- <https://github.com/avo-hq/avo/commit/7891c01e1fba9ca5d7dbccc43d27f385e5d08563>
- <https://github.com/avo-hq/avo>
- <https://github.com/avo-hq/avo/releases/tag/v2.33.3>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/avo/CVE-2023-34103.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5cr9-5jx3-2g39>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5cr9-5jx3-2g39/>. Everything for agents: <https://agentprime.io/llms.txt>.
