# Contao: Improper access control in the table access voter

Advisory record · `GHSA-5974-gfqc-wrcm`

- **Identifiers:** `GHSA-5974-gfqc-wrcm` · `CVE-2026-107851` · `PKSA-b5qj-hq3z-3ry8`
- **State:** Confirmed
- **Severity:** CVSS 4.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-524](https://cwe.mitre.org/data/definitions/524.html) · [CWE-863](https://cwe.mitre.org/data/definitions/863.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-524](https://agentprime.io/advisories/tag/cwe-524.md)
- **Published:** 9 Oct 2026
- **Updated:** 9 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Oct 2026, 20:53 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `contao/core-bundle` (Packagist): affected `>=5.7.0, <5.7.12`; fixed in `5.7.12`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Contao's contao/core-bundle package, versions 5.7.0 up to but not including 5.7.12, has an improper access control flaw in the table access voter that governs backend Data Container table permissions. A low-privileged backend user can, after a table they are allowed to access has been checked in the same request, gain read, create, update and delete access to other tables outside their module permissions, including tables holding member records and newsletter subscriber e-mail addresses. Upgrade contao/core-bundle to 5.7.12 or later, which is the fixed version.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0019, the 9th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:54 UTC: First seen by agentprime
- 31 Oct 2026, 13:54 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-5974-gfqc-wrcm)

## Sources

- [GitHub Advisory Database: GHSA-5974-gfqc-wrcm](https://github.com/advisories/GHSA-5974-gfqc-wrcm)
- [OSV: GHSA-5974-gfqc-wrcm](https://osv.dev/vulnerability/GHSA-5974-gfqc-wrcm)
- <https://github.com/contao/contao/security/advisories/GHSA-5974-gfqc-wrcm>
- <https://github.com/contao/contao/commit/9d6f582a4cc6a758ce11d1043fc9c0ba62c5f4c9>
- <https://github.com/contao/contao>
- <https://github.com/contao/contao/releases/tag/5.7.12>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5974-gfqc-wrcm>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5974-gfqc-wrcm/>. Everything for agents: <https://agentprime.io/llms.txt>.
