# vLLM: GLMGA video sampling permits request-driven CPU and memory exhaustion

Advisory record · `GHSA-58v5-2m8f-94pr`

- **Identifiers:** `GHSA-58v5-2m8f-94pr` · `CVE-2026-105760` · `PYSEC-2026-4307`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 5 Oct 2026
- **Updated:** 15 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Oct 2026, 23:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vllm` (PyPI): affected `>=0.23.0rc2, <0.30.0`; fixed in `0.30.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Affected: vLLM versions >=0.23.0rc2 and <0.30.0, fixed in 0.30.0. An attacker who can send chat completion requests to a video-capable model can supply request-level video options that make the GLMGA sampler build and deduplicate very large index lists, even for a tiny video. This can consume CPU and memory and delay other media requests, causing partial denial of service. Upgrade vLLM to 0.30.0 or later. Workarounds include blocking request-level video options at a gateway, restricting untrusted callers from selecting GLMGA, and applying rate limits and concurrency limits.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0030, the 22nd percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:08 UTC: First seen by agentprime
- 31 Oct 2026, 14:08 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-58v5-2m8f-94pr)

## Sources

- [GitHub Advisory Database: GHSA-58v5-2m8f-94pr](https://github.com/advisories/GHSA-58v5-2m8f-94pr)
- [OSV: GHSA-58v5-2m8f-94pr](https://osv.dev/vulnerability/GHSA-58v5-2m8f-94pr)
- <https://github.com/vllm-project/vllm/security/advisories/GHSA-58v5-2m8f-94pr>
- <https://github.com/vllm-project/vllm/pull/54935>
- <https://github.com/vllm-project/vllm/commit/8b6de0eb9a09ef53f20cf06bd4d17ee264b9c2a7>
- <https://github.com/vllm-project/vllm>
- <https://github.com/vllm-project/vllm/releases/tag/v0.30.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-58v5-2m8f-94pr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-58v5-2m8f-94pr/>. Everything for agents: <https://agentprime.io/llms.txt>.
