# launch-editor: \`fs.existsSync()\` existence check can be bypassed on Windows

Advisory record · `GHSA-587h-7wmj-h5pm`

- **Identifiers:** `GHSA-587h-7wmj-h5pm` · `CVE-2026-112942`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-77](https://cwe.mitre.org/data/definitions/77.html)
- **Tags:** [Command injection](https://agentprime.io/advisories/tag/command-injection.md)
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Oct 2026, 19:48 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `launch-editor` (npm): affected `<2.14.2`; fixed in `2.14.2`
- `vite` (npm): affected `>=8.3.0, <8.3.3 || >=8.2.0, <8.2.4 || >=8.0.0, <8.1.6 || >=7.0.0, <7.3.7 || <6.4.4`; fixed in `8.3.3`, `8.2.4`, `8.1.6`, `7.3.7`, `6.4.4`
- `vite-plus` (npm): affected `<1.1.0`; fixed in `1.1.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The launch-editor npm package before 2.14.2 has a flaw on Windows where its check that a supplied file exists can be bypassed, and the advisory also lists vite and vite-plus as affected. An attacker who controls the file argument, without needing to create a file, could combine this with a separate escaping issue to run OS commands, but only in apps running on Windows. Upgrade launch-editor to 2.14.2, vite to 6.4.4, 7.3.7, 8.1.6, 8.2.4 or 8.3.3 for its release line, or vite-plus to 1.1.0.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.013, the 71st percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-587h-7wmj-h5pm)

## Sources

- [GitHub Advisory Database: GHSA-587h-7wmj-h5pm](https://github.com/advisories/GHSA-587h-7wmj-h5pm)
- [OSV: GHSA-587h-7wmj-h5pm](https://osv.dev/vulnerability/GHSA-587h-7wmj-h5pm)
- <https://github.com/vitejs/launch-editor/security/advisories/GHSA-587h-7wmj-h5pm>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-112942>
- <https://github.com/vitejs/launch-editor/commit/f13cd835d4b8e860b1d4d080ad8a490cc2463679>
- <https://github.com/vitejs/launch-editor>
- <https://github.com/vitejs/launch-editor/releases/tag/v2.14.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-587h-7wmj-h5pm>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-587h-7wmj-h5pm/>. Everything for agents: <https://agentprime.io/llms.txt>.
