# OPKSSH Vulnerable to Authentication Bypass in github.com/openpubkey/opkssh

Advisory record · `GHSA-56wx-66px-9j66`

- **Identifiers:** `GHSA-56wx-66px-9j66` · `CVE-2025-4658` · `GO-2025-3680`
- **State:** Confirmed
- **Severity:** CVSS 9.3 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-305](https://cwe.mitre.org/data/definitions/305.html)
- **Tags:** [CWE-305](https://agentprime.io/advisories/tag/cwe-305.md)
- **Published:** 15 May 2025
- **Updated:** 3 Mar 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 May 2025, 20:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.3: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `github.com/openpubkey/opkssh` (Go): affected `<0.5.0`; fixed in `0.5.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.3 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L`, from CNA (cloudflare)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0034, the 27th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 15 May 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-56wx-66px-9j66](https://github.com/advisories/GHSA-56wx-66px-9j66)
- [OSV: GHSA-56wx-66px-9j66](https://osv.dev/vulnerability/GHSA-56wx-66px-9j66)
- <https://github.com/openpubkey/opkssh/security/advisories/GHSA-56wx-66px-9j66>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-4658>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-56wx-66px-9j66>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-56wx-66px-9j66/>. Everything for agents: <https://agentprime.io/llms.txt>.
