# Spring Boot DevTools remote secret comparison is vulnerable to timing attacks

Advisory record · `GHSA-56v8-86gj-66jp`

- **Identifiers:** `GHSA-56v8-86gj-66jp` · `CVE-2026-40972`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-208](https://cwe.mitre.org/data/definitions/208.html)
- **Tags:** [CWE-208](https://agentprime.io/advisories/tag/cwe-208.md)
- **Published:** 28 Apr 2026
- **Updated:** 6 May 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Apr 2026, 00:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.springframework.boot:spring-boot-devtools` (Maven): affected `>=4.0.0, <4.0.6 || >=3.5.0, <3.5.14 || >=3.4.0, <=3.4.15 || >=3.3.0, <=3.3.18 || <=2.7.32`; fixed in `4.0.6`, `3.5.14`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Spring Boot DevTools (org.springframework.boot:spring-boot-devtools) versions 4.0.0 to before 4.0.6, 3.5.0 to before 3.5.14, 3.4.0 through 3.4.15, 3.3.0 through 3.3.18, and 2.7.32 and earlier are affected. An attacker on the same network as a remote application may be able to use a timing attack against its remote secret comparison and, in extreme cases, recover the secret and upload changed classes for remote code execution. Upgrade to 4.0.6 or 3.5.14; for the 3.4, 3.3 and 2.7 lines, the source lists fixed versions of 3.4.16, 3.3.19 and 2.7.33.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (vmware)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0026, the 18th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:20 UTC: First seen by agentprime
- 31 Oct 2026, 14:20 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-56v8-86gj-66jp)

## Sources

- [GitHub Advisory Database: GHSA-56v8-86gj-66jp](https://github.com/advisories/GHSA-56v8-86gj-66jp)
- [OSV: GHSA-56v8-86gj-66jp](https://osv.dev/vulnerability/GHSA-56v8-86gj-66jp)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-40972>
- <https://github.com/spring-projects/spring-boot>
- <https://spring.io/security/cve-2026-40972>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-56v8-86gj-66jp>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-56v8-86gj-66jp/>. Everything for agents: <https://agentprime.io/llms.txt>.
