# Decidim Cross-site Scripting vulnerability in the processes filter

Advisory record · `GHSA-5652-92r9-3fx9`

- **Identifiers:** `GHSA-5652-92r9-3fx9` · `CVE-2023-34089`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 11 Jul 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 11 Jul 2023, 22:46 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `decidim` (RubyGems): affected `>=0.14.0, <0.26.7 || >=0.27.0, <0.27.3`; fixed in `0.26.7`, `0.27.3`
- `decidim-core` (RubyGems): affected `>=0.14.0, <0.26.7 || >=0.27.0, <0.27.3`; fixed in `0.26.7`, `0.27.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0074, the 54th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-5652-92r9-3fx9)

## Sources

- [GitHub Advisory Database: GHSA-5652-92r9-3fx9](https://github.com/advisories/GHSA-5652-92r9-3fx9)
- [OSV: GHSA-5652-92r9-3fx9](https://osv.dev/vulnerability/GHSA-5652-92r9-3fx9)
- <https://github.com/decidim/decidim/security/advisories/GHSA-5652-92r9-3fx9>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-34089>
- <https://github.com/decidim/decidim>
- <https://github.com/decidim/decidim/releases/tag/v0.26.6>
- <https://github.com/decidim/decidim/releases/tag/v0.26.7>
- <https://github.com/decidim/decidim/releases/tag/v0.27.3>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-core/CVE-2023-34089.yml>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim/CVE-2023-34089.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-5652-92r9-3fx9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-5652-92r9-3fx9/>. Everything for agents: <https://agentprime.io/llms.txt>.
