# undici vulnerable to Denial of Service via unhandled exception in the decompress interceptor

Advisory record · `GHSA-55wc-3pg8-jfw6`

- **Identifiers:** `GHSA-55wc-3pg8-jfw6` · `CVE-2026-87029`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-248](https://cwe.mitre.org/data/definitions/248.html)
- **Tags:** [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md)
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Oct 2026, 19:02 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `undici` (npm): affected `>=7.15.0, <7.30.1 || >=8.0.0, <8.12.2`; fixed in `7.30.1`, `8.12.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (openjs)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0026, the 17th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-55wc-3pg8-jfw6)

## Sources

- [GitHub Advisory Database: GHSA-55wc-3pg8-jfw6](https://github.com/advisories/GHSA-55wc-3pg8-jfw6)
- [OSV: GHSA-55wc-3pg8-jfw6](https://osv.dev/vulnerability/GHSA-55wc-3pg8-jfw6)
- <https://github.com/nodejs/undici/security/advisories/GHSA-55wc-3pg8-jfw6>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-87029>
- <https://github.com/nodejs/undici/commit/63cba7712ca012b2603c6aeeb4c72d8692332cd0>
- <https://github.com/nodejs/undici/commit/f851f315db1f2acce0ea668f88d9d0fa61c8420c>
- <https://cna.openjsf.org/security-advisories.html>
- <https://github.com/nodejs/undici>
- <https://github.com/nodejs/undici/releases/tag/v7.30.1>
- <https://github.com/nodejs/undici/releases/tag/v8.12.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-55wc-3pg8-jfw6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-55wc-3pg8-jfw6/>. Everything for agents: <https://agentprime.io/llms.txt>.
