# Trix is vulnerable to XSS through JSON deserialization bypass in drag-and-drop (Level0InputController)

Advisory record · `GHSA-53p3-c7vp-4mcc`

- **Identifiers:** `GHSA-53p3-c7vp-4mcc` · `CVE-2026-73427`
- **State:** Confirmed
- **Severity:** CVSS 2.1 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 29 Mar 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Mar 2026, 15:22 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `trix` (npm): affected `<2.1.18`; fixed in `2.1.18`
- `action_text-trix` (RubyGems): affected `<2.1.18`; fixed in `2.1.18`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.1 Low, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0057, the 47th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 29 Mar 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-53p3-c7vp-4mcc](https://github.com/advisories/GHSA-53p3-c7vp-4mcc)
- [OSV: GHSA-53p3-c7vp-4mcc](https://osv.dev/vulnerability/GHSA-53p3-c7vp-4mcc)
- <https://github.com/basecamp/trix/security/advisories/GHSA-53p3-c7vp-4mcc>
- <https://github.com/basecamp/trix/commit/9c0a993d9fc2ffe9d56b013b030bc238f9c0557c>
- <https://github.com/basecamp/trix>
- <https://github.com/basecamp/trix/releases/tag/v2.1.18>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/action_text-trix/GHSA-53p3-c7vp-4mcc.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-53p3-c7vp-4mcc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-53p3-c7vp-4mcc/>. Everything for agents: <https://agentprime.io/llms.txt>.
