# xwiki vulnerable to Improper Handling of Exceptional Conditions

Advisory record · `GHSA-52vf-hvv3-98h7`

- **Identifiers:** `GHSA-52vf-hvv3-98h7` · `CVE-2023-26479`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-755](https://cwe.mitre.org/data/definitions/755.html)
- **Tags:** [CWE-755](https://agentprime.io/advisories/tag/cwe-755.md)
- **Published:** 3 Mar 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Mar 2023, 22:53 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.xwiki.platform:xwiki-platform-rendering-parser` (Maven): affected `>=6.0, <13.10.10 || >=14.0, <14.4.6 || >=14.5, <14.9-rc-1`; fixed in `13.10.10`, `14.4.6`, `14.9-rc-1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of the xwiki-platform-rendering-parser Maven package from 6.0 up to 13.10.10, from 14.0 up to 14.4.6, and from 14.5 up to 14.9-rc-1 are affected. A user with write rights can insert deeply nested group content that makes the parser throw a StackOverflowError, which can make pages such as the user index and page index unusable. Upgrade to 13.10.10, 14.4.6, or 14.9-rc-1, depending on your release line. Increasing the JVM stack size with the -Xss parameter is a temporary workaround only, since it does not stop the issue from recurring with other content.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.011, the 65th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:18 UTC: First seen by agentprime
- 31 Oct 2026, 14:18 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-52vf-hvv3-98h7)

## Sources

- [GitHub Advisory Database: GHSA-52vf-hvv3-98h7](https://github.com/advisories/GHSA-52vf-hvv3-98h7)
- [OSV: GHSA-52vf-hvv3-98h7](https://osv.dev/vulnerability/GHSA-52vf-hvv3-98h7)
- <https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-52vf-hvv3-98h7>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-26479>
- <https://github.com/xwiki/xwiki-platform/commit/e5b82cd98072464196a468b8f7fe6396dce142a7>
- <https://github.com/xwiki/xwiki-platform>
- <https://jira.xwiki.org/browse/XWIKI-19838>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-52vf-hvv3-98h7>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-52vf-hvv3-98h7/>. Everything for agents: <https://agentprime.io/llms.txt>.
