# Signal K resources API path traversal can disclose the JWT signing secret and enable remote code execution

Advisory record · `GHSA-4xm8-rg9h-jhq2`

- **Identifiers:** `GHSA-4xm8-rg9h-jhq2`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md)
- **Published:** 30 Oct 2026
- **Updated:** 30 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Oct 2026, 22:57 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `signalk-server` (npm): affected `>=2.0.0, <2.34.0`; fixed in `2.34.0`
- `@signalk/resources-provider` (npm): affected `>=1.0.0, <1.5.3`; fixed in `1.5.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 13:32 UTC: First seen by agentprime
- 31 Oct 2026, 13:32 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4xm8-rg9h-jhq2)

## Sources

- [GitHub Advisory Database: GHSA-4xm8-rg9h-jhq2](https://github.com/advisories/GHSA-4xm8-rg9h-jhq2)
- [OSV: GHSA-4xm8-rg9h-jhq2](https://osv.dev/vulnerability/GHSA-4xm8-rg9h-jhq2)
- <https://github.com/SignalK/signalk-server/security/advisories/GHSA-4xm8-rg9h-jhq2>
- <https://github.com/SignalK/signalk-server/commit/83689f040d7e90280dddc643f44f3e4ce348fbb1>
- <https://github.com/SignalK/signalk-server>
- <https://github.com/SignalK/signalk-server/releases/tag/v2.34.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4xm8-rg9h-jhq2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4xm8-rg9h-jhq2/>. Everything for agents: <https://agentprime.io/llms.txt>.
