# Apache Tomcat util accepted misconfigured CRLs

Advisory record · `GHSA-4x29-79gh-6v8q`

- **Identifiers:** `GHSA-4x29-79gh-6v8q` · `BIT-tomcat-2026-53434` · `CVE-2026-53434`
- **State:** Confirmed
- **Severity:** CVSS 9.1 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-390](https://cwe.mitre.org/data/definitions/390.html)
- **Tags:** [CWE-390](https://agentprime.io/advisories/tag/cwe-390.md)
- **Published:** 29 Jun 2026
- **Updated:** 23 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Jun 2026, 21:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.1: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.apache.tomcat:tomcat-util` (Maven): affected `>=11.0.0-M1, <11.0.23 || >=10.1.0-M7, <10.1.56 || >=9.0.83, <9.0.119`; fixed in `11.0.23`, `10.1.56`, `9.0.119`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache Tomcat's tomcat-util package, in versions 11.0.0-M1 through 11.0.22, 10.1.0-M7 through 10.1.55, and 9.0.83 through 9.0.118, ignores invalid Certificate Revocation Lists configured for an FFM-based connector, so revoked or invalid client certificates may be accepted. The source does not describe the attacker's position or required access. Upgrade to 11.0.23, 10.1.56, or 9.0.119, depending on your release line.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.1 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0059, the 48th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4x29-79gh-6v8q)

## Sources

- [GitHub Advisory Database: GHSA-4x29-79gh-6v8q](https://github.com/advisories/GHSA-4x29-79gh-6v8q)
- [OSV: GHSA-4x29-79gh-6v8q](https://osv.dev/vulnerability/GHSA-4x29-79gh-6v8q)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-53434>
- <https://github.com/apache/tomcat/commit/7f8ecdbd930d8c5a7fae73aa0eec9124d919e2f5>
- <https://github.com/apache/tomcat/commit/c48ac39c27f4494f8c96b9d56a487253e362d276>
- <https://github.com/apache/tomcat/commit/feec60d6099727db6f911534f6a0f6926ebab070>
- <https://lists.apache.org/thread/x510lbq0sfrd1qyo7q3r1mpllgpdcosk>
- <http://www.openwall.com/lists/oss-security/2026/06/29/22>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4x29-79gh-6v8q>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4x29-79gh-6v8q/>. Everything for agents: <https://agentprime.io/llms.txt>.
