# http-proxy-middleware can call writeBody twice because "else if" is not used

Advisory record · `GHSA-4www-5p9h-95mh`

- **Identifiers:** `GHSA-4www-5p9h-95mh` · `CVE-2025-32996`
- **State:** Confirmed
- **Severity:** CVSS 4.0 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-670](https://cwe.mitre.org/data/definitions/670.html)
- **Tags:** [CWE-670](https://agentprime.io/advisories/tag/cwe-670.md)
- **Published:** 15 Apr 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Apr 2025, 03:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `http-proxy-middleware` (npm): affected `>=1.3.0, <2.0.8 || >=3.0.0, <3.0.4`; fixed in `2.0.8`, `3.0.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.0 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:L`, from CNA (mitre)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0047, the 40th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 15 Apr 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-4www-5p9h-95mh](https://github.com/advisories/GHSA-4www-5p9h-95mh)
- [OSV: GHSA-4www-5p9h-95mh](https://osv.dev/vulnerability/GHSA-4www-5p9h-95mh)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-32996>
- <https://github.com/chimurai/http-proxy-middleware/pull/1089>
- <https://github.com/chimurai/http-proxy-middleware/commit/020976044d113fc0bcbbaf995e91d05e2829a145>
- <https://github.com/chimurai/http-proxy-middleware>
- <https://github.com/chimurai/http-proxy-middleware/releases/tag/v2.0.8>
- <https://github.com/chimurai/http-proxy-middleware/releases/tag/v3.0.4>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4www-5p9h-95mh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4www-5p9h-95mh/>. Everything for agents: <https://agentprime.io/llms.txt>.
