# False-negative validation results in MINT transactions with invalid baton

Advisory record · `GHSA-4w97-57v2-3w44`

- **Identifiers:** `GHSA-4w97-57v2-3w44` · `CVE-2020-11072`
- **State:** Confirmed
- **Severity:** CVSS 8.6 High
- **Critical:** No
- **Weakness (CWE):** [CWE-697](https://cwe.mitre.org/data/definitions/697.html)
- **Tags:** [CWE-697](https://agentprime.io/advisories/tag/cwe-697.md)
- **Published:** 12 May 2020
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 May 2020, 00:45 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `slp-validate` (npm): affected `<1.2.1`; fixed in `1.2.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.6 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.010, the 64th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 12 May 2020. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-4w97-57v2-3w44](https://github.com/advisories/GHSA-4w97-57v2-3w44)
- [OSV: GHSA-4w97-57v2-3w44](https://osv.dev/vulnerability/GHSA-4w97-57v2-3w44)
- <https://github.com/simpleledger/slp-validate.js/security/advisories/GHSA-4w97-57v2-3w44>
- <https://github.com/simpleledger/slp-validate/security/advisories/GHSA-4w97-57v2-3w44>
- <https://nvd.nist.gov/vuln/detail/CVE-2020-11072>
- <https://github.com/simpleledger/slp-validate/commit/cde95c0c6470dceb4f023cd462f904135ebd73e7>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4w97-57v2-3w44>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4w97-57v2-3w44/>. Everything for agents: <https://agentprime.io/llms.txt>.
