# vm2 vulnerable to Arbitrary Code Execution

Advisory record · `GHSA-4w2j-2rg4-5mjw`

- **Identifiers:** `GHSA-4w2j-2rg4-5mjw` · `CVE-2022-25893`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-94](https://cwe.mitre.org/data/definitions/94.html) · [CWE-471](https://cwe.mitre.org/data/definitions/471.html)
- **Tags:** [Code injection](https://agentprime.io/advisories/tag/code-injection.md) · [CWE-471](https://agentprime.io/advisories/tag/cwe-471.md)
- **Published:** 21 Dec 2022
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Dec 2022, 06:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `vm2` (npm): affected `<3.9.10`; fixed in `3.9.10`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`, from CNA (snyk)

- **CISA KEV:** Not listed.
- **EPSS:** 0.015, the 75th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 21 Dec 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-4w2j-2rg4-5mjw](https://github.com/advisories/GHSA-4w2j-2rg4-5mjw)
- [OSV: GHSA-4w2j-2rg4-5mjw](https://osv.dev/vulnerability/GHSA-4w2j-2rg4-5mjw)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-25893>
- <https://github.com/patriksimek/vm2/issues/444>
- <https://github.com/patriksimek/vm2/pull/445>
- <https://github.com/patriksimek/vm2/pull/445/commits/3a9876482be487b78a90ac459675da7f83f46d69>
- <https://github.com/patriksimek/vm2>
- <https://security.snyk.io/vuln/SNYK-JS-VM2-2990237>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4w2j-2rg4-5mjw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4w2j-2rg4-5mjw/>. Everything for agents: <https://agentprime.io/llms.txt>.
