# pypdf has possible large memory usage for exceptions in strict mode

Advisory record · `GHSA-4vqv-7265-gm2w`

- **Identifiers:** `GHSA-4vqv-7265-gm2w` · `CVE-2026-119207`
- **State:** Confirmed
- **Severity:** CVSS 7.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-405](https://cwe.mitre.org/data/definitions/405.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [CWE-405](https://agentprime.io/advisories/tag/cwe-405.md)
- **Published:** 30 Oct 2026
- **Updated:** 30 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Oct 2026, 23:08 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pypdf` (PyPI): affected `<6.21.3`; fixed in `6.21.3`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The pypdf PDF library is vulnerable in versions before 6.21.3, where strict mode can use large amounts of memory when handling exceptions. An attacker who supplies a crafted PDF containing an invalid dictionary can trigger this excessive memory use. Upgrade to pypdf 6.21.3, which contains the fix; if upgrading is not yet possible, the source suggests applying the changes from the referenced pull request.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.1 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0022, the 12th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 29 Oct 2026, 21:17 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2026-119207)
- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4vqv-7265-gm2w)

## Sources

- [GitHub Advisory Database: GHSA-4vqv-7265-gm2w](https://github.com/advisories/GHSA-4vqv-7265-gm2w)
- [OSV: GHSA-4vqv-7265-gm2w](https://osv.dev/vulnerability/GHSA-4vqv-7265-gm2w)
- <https://github.com/py-pdf/pypdf/security/advisories/GHSA-4vqv-7265-gm2w>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-119207>
- <https://github.com/py-pdf/pypdf/pull/4265>
- <https://github.com/py-pdf/pypdf/commit/64270258c0eced720f7960aecf8cef31afd39f8d>
- <https://github.com/py-pdf/pypdf>
- <https://github.com/py-pdf/pypdf/releases/tag/6.21.3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4vqv-7265-gm2w>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4vqv-7265-gm2w/>. Everything for agents: <https://agentprime.io/llms.txt>.
