# systeminformation has path traversal in Linux networkStats() that allows symlink-based file disclosure outside /sys/class/net

Advisory record · `GHSA-4vjg-vx72-qq4g`

- **Identifiers:** `GHSA-4vjg-vx72-qq4g` · `CVE-2026-116673`
- **State:** Confirmed
- **Severity:** CVSS 3.3 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html) · [CWE-59](https://cwe.mitre.org/data/definitions/59.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md)
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Oct 2026, 21:13 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `systeminformation` (npm): affected `<5.33.14`; fixed in `5.33.14`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GHSA-4vjg-vx72-qq4g affects the npm package systeminformation before 5.33.14, where the Linux networkStats() function builds /sys/class/net paths from the caller-supplied interface value without confining the resolved path to that directory. An attacker who can control that value and create a symlink in the path could cause the function to return the first line of a file readable by the Node process. The advisory says remote exploitability through an application was not demonstrated. Upgrade to systeminformation 5.33.14 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.3 Low, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0013, the 2nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:32 UTC: First seen by agentprime
- 31 Oct 2026, 13:32 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4vjg-vx72-qq4g)

## Sources

- [GitHub Advisory Database: GHSA-4vjg-vx72-qq4g](https://github.com/advisories/GHSA-4vjg-vx72-qq4g)
- [OSV: GHSA-4vjg-vx72-qq4g](https://osv.dev/vulnerability/GHSA-4vjg-vx72-qq4g)
- <https://github.com/sebhildebrandt/systeminformation/security/advisories/GHSA-4vjg-vx72-qq4g>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-116673>
- <https://github.com/sebhildebrandt/systeminformation/commit/8d294b3139fec654a912969ac898037578a218cd>
- <https://github.com/sebhildebrandt/systeminformation>
- <https://github.com/sebhildebrandt/systeminformation/releases/tag/v5.33.14>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4vjg-vx72-qq4g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4vjg-vx72-qq4g/>. Everything for agents: <https://agentprime.io/llms.txt>.
