# Ruby SAML allows a SAML authentication bypass due to DOCTYPE handling (parser differential)

Advisory record · `GHSA-4vc4-m8qh-g8jm`

- **Identifiers:** `GHSA-4vc4-m8qh-g8jm` · `BIT-gitlab-2025-25291` · `CVE-2025-25291`
- **State:** Confirmed
- **Severity:** CVSS 9.3 Critical
- **Critical:** Yes: CVSS 9+, CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-347](https://cwe.mitre.org/data/definitions/347.html) · [CWE-436](https://cwe.mitre.org/data/definitions/436.html)
- **Tags:** [Weak cryptography or TLS](https://agentprime.io/advisories/tag/weak-crypto.md) · [CWE-436](https://agentprime.io/advisories/tag/cwe-436.md)
- **Published:** 12 Mar 2025
- **Updated:** 4 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Mar 2025, 20:20 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.3: 9.0 or more.
- CVSS score 9.3 (7.0 or more) and EPSS 0.21 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `ruby-saml` (RubyGems): affected `<1.12.4 || >=1.13.0, <1.18.0`; fixed in `1.12.4`, `1.18.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.3 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.21, the 97th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 12 Mar 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-4vc4-m8qh-g8jm](https://github.com/advisories/GHSA-4vc4-m8qh-g8jm)
- [OSV: GHSA-4vc4-m8qh-g8jm](https://osv.dev/vulnerability/GHSA-4vc4-m8qh-g8jm)
- <https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-4vc4-m8qh-g8jm>
- <https://github.com/omniauth/omniauth-saml/security/advisories/GHSA-hw46-3hmr-x9xv>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-25291>
- <https://github.com/SAML-Toolkits/ruby-saml/commit/e76c5b36bac40aedbf1ba7ffaaf495be63328cd9>
- <https://github.com/SAML-Toolkits/ruby-saml/commit/e9c1cdbd0f9afa467b585de279db0cbd0fb8ae97>
- <https://about.gitlab.com/releases/2025/03/12/patch-release-gitlab-17-9-2-released>
- <https://github.blog/security/sign-in-as-anyone-bypassing-saml-sso-authentication-with-parser-differentials>
- <https://github.com/SAML-Toolkits/ruby-saml>
- <https://github.com/SAML-Toolkits/ruby-saml/releases/tag/v1.12.4>
- <https://github.com/SAML-Toolkits/ruby-saml/releases/tag/v1.18.0>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/CVE-2025-25291.yml>
- <https://lists.debian.org/debian-lts-announce/2025/04/msg00011.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4vc4-m8qh-g8jm>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4vc4-m8qh-g8jm/>. Everything for agents: <https://agentprime.io/llms.txt>.
