# Apache OpenNLP DictionaryEntryPersistor Vulnerable to XML External Entity (XXE) via Unsanitized Dictionary Parsing

Advisory record · `GHSA-4v8g-86x5-3vrc`

- **Identifiers:** `GHSA-4v8g-86x5-3vrc` · `CVE-2026-40682`
- **State:** Confirmed
- **Severity:** CVSS 9.1 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-611](https://cwe.mitre.org/data/definitions/611.html)
- **Tags:** [XML external entities (XXE)](https://agentprime.io/advisories/tag/xxe.md)
- **Published:** 4 May 2026
- **Updated:** 2 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 4 May 2026, 18:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.1: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.apache.opennlp:opennlp-tools` (Maven): affected `>=2.0.0, <2.5.9 || >=3.0.0-M1, <3.0.0-M3 || <1.9.5`; fixed in `2.5.9`, `3.0.0-M3`, `1.9.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.1 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0050, the 42nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4v8g-86x5-3vrc)

## Sources

- [GitHub Advisory Database: GHSA-4v8g-86x5-3vrc](https://github.com/advisories/GHSA-4v8g-86x5-3vrc)
- [OSV: GHSA-4v8g-86x5-3vrc](https://osv.dev/vulnerability/GHSA-4v8g-86x5-3vrc)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-40682>
- <https://access.redhat.com/security/cve/CVE-2026-40682>
- <https://bugzilla.redhat.com/show_bug.cgi?id=2466484>
- <https://github.com/apache/opennlp>
- <https://lists.apache.org/thread/r6jpt0qr9nj67gqhppqg7jxf8vsbo0w6>
- <https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40682.json>
- <http://www.openwall.com/lists/oss-security/2026/05/01/19>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4v8g-86x5-3vrc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4v8g-86x5-3vrc/>. Everything for agents: <https://agentprime.io/llms.txt>.
