# Vyper: Call stack corruption when passing complex type containing non-base type members as argument

Advisory record · `GHSA-4v7v-gqf9-ww2g`

- **Identifiers:** `GHSA-4v7v-gqf9-ww2g` · `CVE-2020-37287`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-131](https://cwe.mitre.org/data/definitions/131.html) · [CWE-682](https://cwe.mitre.org/data/definitions/682.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [CWE-682](https://agentprime.io/advisories/tag/cwe-682.md)
- **Published:** 6 Oct 2026
- **Updated:** 24 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Oct 2026, 15:22 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vyper` (PyPI): affected `<0.2.6`; fixed in `0.2.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Vyper versions before 0.2.6 mishandle complex arguments such as multi-dimensional arrays or structs with non-base-type members, passed to internal or external functions, because the compiler assumes each subtype occupies 32 bytes. This corrupts the call stack and produces incorrect output. The source does not describe what an attacker would need beyond writing contracts that use such arguments. Upgrade to Vyper 0.2.6 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0025, the 16th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4v7v-gqf9-ww2g)

## Sources

- [GitHub Advisory Database: GHSA-4v7v-gqf9-ww2g](https://github.com/advisories/GHSA-4v7v-gqf9-ww2g)
- [OSV: GHSA-4v7v-gqf9-ww2g](https://osv.dev/vulnerability/GHSA-4v7v-gqf9-ww2g)
- <https://github.com/vyperlang/vyper/security/advisories/GHSA-4v7v-gqf9-ww2g>
- <https://github.com/vyperlang/vyper/issues/2183>
- <https://github.com/vyperlang/vyper/pull/2184>
- <https://github.com/vyperlang/vyper/commit/0be02b7331e8febe79d5a4218829c72e30417a29>
- <https://github.com/vyperlang/vyper>
- <https://github.com/vyperlang/vyper/releases/tag/v0.2.6>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4v7v-gqf9-ww2g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4v7v-gqf9-ww2g/>. Everything for agents: <https://agentprime.io/llms.txt>.
