# RabbitMQ amqp091-go: Denial of Service via Malicious Field Length in AMQP Client

Advisory record · `GHSA-4v58-74mf-rjx3`

- **Identifiers:** `GHSA-4v58-74mf-rjx3` · `CVE-2026-77412` · `GO-2026-6494`
- **State:** Confirmed
- **Severity:** CVSS 8.9 High
- **Critical:** No
- **Weakness (CWE):** [CWE-681](https://cwe.mitre.org/data/definitions/681.html)
- **Tags:** [CWE-681](https://agentprime.io/advisories/tag/cwe-681.md)
- **Published:** 17 Sept 2026
- **Updated:** 1 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Sept 2026, 17:04 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/rabbitmq/amqp091-go` (Go): affected `<1.13.0`; fixed in `1.13.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> RabbitMQ amqp091-go versions before 1.13.0 are vulnerable. A malicious or compromised AMQP server can send a frame with a crafted byte-array field length that causes an unrecovered runtime panic, crashing the client process. No fix is listed other than upgrading to 1.13.0, which is the fixed version.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.9 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0052, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:12 UTC: First seen by agentprime
- 31 Oct 2026, 14:12 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4v58-74mf-rjx3)

## Sources

- [GitHub Advisory Database: GHSA-4v58-74mf-rjx3](https://github.com/advisories/GHSA-4v58-74mf-rjx3)
- [OSV: GHSA-4v58-74mf-rjx3](https://osv.dev/vulnerability/GHSA-4v58-74mf-rjx3)
- <https://github.com/rabbitmq/amqp091-go/security/advisories/GHSA-4v58-74mf-rjx3>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-77412>
- <https://github.com/rabbitmq/amqp091-go/pull/344>
- <https://github.com/rabbitmq/amqp091-go/commit/669b42bf7b1db76bc6d4973e3634247f680accbf>
- <https://github.com/rabbitmq/amqp091-go>
- <https://github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4v58-74mf-rjx3>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4v58-74mf-rjx3/>. Everything for agents: <https://agentprime.io/llms.txt>.
